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Introduction
Have you been programming in SAS for a while and aren't sure HOW 

or IF Enterprise Guide can help you?

This presentation demonstrates how SAS programmers can use SAS 
Enterprise Guide as their primary interface to the SAS system while 
maintaining the flexibility of writing their own customized code. 
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Introduction
We explore
 navigating and customizing the SAS Enterprise Guide environment

 using SAS Enterprise Guide to access existing programs and enhance 
processing

 exploiting the enhanced development environment including syntax 
completion and built-in function help

 using Code Analyzer, Report Builder, and Document Builder

 adding Project Parameters to generalize the usability of programs and 
processes

 leveraging built-in capabilities available in SAS Enterprise Guide to further 
enhance the information you deliver.

Enterprise Guide version 6.1 will be used.
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Part 1:   I know how to program in SAS 
– How do I navigate EG?

With all of the windows and views and menus 
available in EG, it's hard to know where to start

Task Status

Project View

Process Flow

Command Menu Task List

Server List Active Data menu

Project Tree
SAS Folders
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How do I navigate EG?

First off, the basics..  

Main Menu   
» Menu bar at the top of the screen enables logical 

access to tasks and views.

The Process Flow view
» Displays all of the items in your project (code, tasks, 

and results) and the connections between them.

• Select View → Process Flow or F4 or select 
the Process Flow tool.
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How do I navigate EG?

• Select View → Project Tree

The Project Tree view
- Provides a hierarchical view of the items in the 
project and their results (similar to Windows 
Explorer).



7

Part 2: Understanding Your Data –
Enterprise Guide Makes it Easy!

Before you start any new programming task, you first need 
to understand the data. 

 The Data Explorer tool enables you to look at the 
values and composition of your data 

 Be sure that the data actually contains what you are 
expecting before you use it.
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Data Explorer – replaces lots of code!

Why do I LOVE the Data Explorer?
Avoid typing / running lots of code
» proc contents
» proc means
» proc univariate
» proc freq
» proc gchart
» proc gplot
» proc DOWNLOAD
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Using the Data Explorer

You can use either  the Server View or the Main Menu to 
access the Data Explorer.  

 In the Server View, expand the Servers and Libraries by 
selecting the plus sign

 Right Click on a dataset and select Explorer
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Using the Data Explorer

 In the Data View, select a subset of the columns and 
request Sales for Asia only.  

Helpful hint:   The updates appear to the right under Pending Updates. The 
updates are not applied until you select Apply Updates.  To remove 

Pending Updates, select the X beside the update.

 In the Quick Stats view, Click on Click to Run all 
Statistics

 Click on the charts generated for the Region column
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Reminders - Data Explorer

Pending Updates - when selecting columns or rows 
The updates appear to the right under Pending Updates. 

- updates are not applied until you select Apply Updates.
To remove Pending Updates, select the X beside the update.

Statistics
In the Quick Stats view, Select Click to Run all Statistics

Optionally, run statistics on just select columns
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Using the Data Explorer

 Using the Data Exploration tool, you are able to get a 
general understanding of what your data contains before 
you start to use it in your analysis and reporting.  

Now that we’ve seen the data and have ruled out issues 
that could skew our results, we are ready to use Enterprise 
Guide to produce reporting.
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Part 3:   Here is my favorite program
- how do I run it in EG (and improve it)???? 

/*******************************************************************/
/*  Example Program 1 - Output Excel Spreadsheet w/ Shoes data     */
/*******************************************************************/
data Ex_Shoes_Data;
set sashelp.shoes;
AverageSalesPerStore = sales / stores;
label AverageSalesPerStore = 'Average Sales Per Store';
format AverageSalesPerStore dollar12.2;

run;

ods listing close; 
ods tagsets.ExcelXP path ='C:\HOW-01.Marje.Fecht'
file='EG Basic_Report.xls' style=statdoc
options (sheet_name = 'Example 1' 

frozen_headers = 'Yes'    autofilter = 'All' );    title "Simple SAS 
Code Example 1";

proc print data=Ex_Shoes_Data noobs label ;    
run;
ods tagsets.ExcelXP close;    ods listing;

/*******************************************************************/
/*  Create PDF Report                                              */
/*******************************************************************/
ods listing close; 
ods pdf file ='C:\HOW-01.Marje.Fecht\EG Shoes_Report.pdf';
proc report data = Ex_Shoes_Data;

column ("Location" (Region Subsidiary Stores))
Product
("Sales"    (Sales AverageSalesPerStore))
;

define region / order "Region";    define Subsidiary / order "Subsidiary";
define Stores / display "Number of Stores";
define Product / display "Product";
define Sales / Sum "Sales";
define AverageSalesPerStore / Sum "Avg Sales per Store";
break after region / summarize;   rbreak after / summarize;
run;
ods pdf close;    
ods listing; 
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Running existing code

• From the Main Menu, File → Open → Program to run an 
existing program
• Navigate to Program_1.sas and select Open.

Enterprise Guide enables you to easily run existing SAS programs.  
Your programs will continue to ‘live’ where they are now and can be 
updated using Enterprise Guide.

Let’s run Program_1.sas and THEN review the process and 
navigation.
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Running existing code

The code opens in a new Tab window in Enterprise Guide.  

The Content Pane has a Program context toolbar that allows you to run 
your code.

A Program_1 code node has been added to the workspace in the     
Project Tree and Process Flow views.      

Notice the shortcut symbol on the Code node reminding you that this is a 
pointer to the originally stored .sas code.

• Run the program by right clicking anywhere in the code node and 
selecting Run On Local OR by selecting Run from the context menu. 
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Viewing the LOG and Results

•The results open in separate tabs (Proc Print and Proc Report)

•The LOG is a tab in the Program context menu bar.  Select the tab 
to view it

•To review the resulting Excel Report, use Windows Explorer to 
open the Workshop folder

•Double click on the Excel Report: EG Basic_Report.xls

Note that the Context based menu bar changes based on 
what Tab you’ve selected.

We will be using the Shoes Dataset from SASHELP throughout 
this Workshop.
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Customizing the Windowing Environment

 All windows can be docked and undocked

 Resize the windows to make the best use of your real estate

 Display windows that you need and use

 Your ‘nice to have’ windows can be set to auto hide.

Helpful Hint: Don’t like the set up? 
Select Restore Window Layout from the Options Window.
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Splitting your screen
Enterprise Guide provides split screen options that enable you to 

explore tasks, programs and data side-by-side.

Option 1: Split screen to view different sections of the same tab
• Right click on the view you are looking at
• Select Split. Select Stacked, Side by Side or Both

Option 2:  Split screen to view different tabs
• Select View from the Main Menu
• Select Workspace layout
• Select Stacked or side by side

Each view will have a drop down at the top left corner that allows 
you to select what you want to view.
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Goodies in the Program editor view

Integrated SAS documentation:
If you mouse over a SAS keyword, a pop up window shows you the 

SAS documentation describing the keyword and the syntax. 
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Goodies in the Program editor view
Syntax Suggestion / Autocomplete when coding:
When you enter the first 2 letters of a SAS keyword (ie. PROC 

statement or option), a list will pop up of possible keywords you 
can select from.  This includes available PROC options.
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Goodies in the Program editor view

Syntax suggestions for Macro Variables and Macro:
• for User defined Macro variables 

• for User defined Macros

• only those that are defined within the active SAS program
 Does not include macros and macro variables automatically 

created through an autoexec
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Goodies in the Program editor view

Autocomplete for SAS libraries, Datasets and 
Dataset column names:



23

Goodies in the Program editor view

Parenthesis Matching:
• Great for debugging macros and SQL code

• Also works for brackets ([  ]) and braces ({ })
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That’s all great but… 
HOW DO I TURN IT OFF????

Helpful Hint:
To turn one, many or ALL 

autocomplete features 
off, update your 
Enhanced Editor 
Options 
Tools – Options –
SAS Program –
Editor Options
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So far so good…
but what if I need code changes

To change your code, you just need to 

 navigate to the code node

 open the code

 make changes and save

 and then rerun the code.
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One Proc Step at a time…

Helpful Hint: What if you only want to run sections of the 
code?   

Highlighting and submitting works the same as using the SAS 
Editor in Display Manager.

When rerunning code you get the following message:
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Resubmitting Code

If you select YES – the code is rerun and the results and log are replaced

If you select NO – a new version of the Code node is added to your 
project with its own results and log.

Helpful Hint: Keeping separate results can be useful, BUT rename 
the new version of the code node to something meaningful….

When Prompted with Do you want to replace the code from the 
previous run? - Select Yes

Note: Throughout the workshop, you will always replace the code 
from the previous run when resubmitting code.
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Working with Datasets
When we ran Program_1, the generated dataset opened in a 

new tab called Output.  

What if your program creates more than one dataset?

A drop down appears at the top of the output tab.  This lets you 
select which output dataset you want to look at.

Helpful Hint:  The output tab is 
always open.  To close a dataset 
that Enterprise Guide sees as open, 
right click on the dataset and select 
Close Data. 
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Part 4:   WOW – that was fun
- are graphics easy too?

Using the Ex_Shoes_Data dataset, 

create a Vertical Bar chart of Sales by Region

• Select Tasks → Graph → Bar Chart from the main menu.  
This will open the Bar Chart Wizard

• In the Bar Chart screen, double click on Simple Vertical Bar

• In the Task Roles screen:

• Drag Region to Column to Chart

• Drag Sales to Sum of.
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Producing a Vertical Bar Chart

• In the Appearance → Layout, uncheck the 2D box and 
then change the Shape to Cylinder from the drop down list

• In the Titles screen: 

• Select Graph

• Uncheck Use Default Text

• enter a title for the graph.
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Producing a Vertical Bar Chart

• Select Run to create the Bar Chart

The bar chart opens automatically in a new Tab in the EG 
session.  

The context menu bar now allows us to see the input data, 
the code that was run, the log and the results.

Helpful Hint: The task or code node that is currently running 
will be highlighted in green in the Process Flow View.  
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Can I Borrow the Code?

Leveraging Code generated by the Built in Tasks
You now have "correct" code!   

How can you REUSE the code elsewhere?

• In the Context menu bar in the Process Flow Window, 
select the Code tab

• Highlight the AXIS, TITLE, FOOTNOTE, and PROC 
GCHART statements

• Right click anywhere on highlighted code, and select Copy

• Move to the Process Flow Window.
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Borrowing the Code EG created
Insert the copied code into a new program
• Switch back to the original Process Flow

• Select File → New → Program.  A new code node opens

• Paste the copied code – CNTL-V or right click and select Paste

• Change the dataset name on the PROC GCHART statement to
Ex_Shoes_Data

• Save the new code File → Save Program As → Local Computer and provide 
the name program_2.sas

• Submit the new code by selecting Run.

Helpful Hint:  The Task Status Window will show you the 
status of the code or task you are running.  
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Customizing the Graph Format

Helpful Hint: By default, graphs are generated as interactive 
ActiveX graphs.  When creating multiple graphs, ActiveX 
can use a lot of system resources.  You can change the 
default to a static format such as JPEG or GIF in the Graph 
Results settings in the Options Window.

Select Tools → Options → Results → Graph

Change your Graph Format by selecting one of the other 
formats in the drop down list.



35

Part 5: A New way to Organize your SAS 
Programs
 Logical steps in the program can be broken into separate 

code nodes

 Code nodes can be linked together in the Process flow 
window

 The Process Flow provides a clear picture of the steps and 
results of the SAS code.

Helpful Hint: If project logging is turned on, the log represents a 
running log of the entire project.  This aggregated log is 
created in addition to the individual logs for each node.

To turn on, select Project Log in the context menu and then 
select Turn On
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Building your own Process Flow

 In the original Process Flow…

 Link the new Program_2 code node to the Program_1 code 
node
 Right click on the Program_1 code node in the Process 

Flow window
 Select Link Program_1  to…
 Select Program_2, and OK.

Helpful Hint: To remove a link between tasks or Code nodes, 
right click anywhere on the joining arrow and select Delete.
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Run your flow, again and again….

To run both code nodes,

 Right click on the Program_1 code node

 Select Run Branch From Program_1.

We’ve created our first flow in Enterprise Guide!
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Shouldn’t I save all of this?

To save the Project so it is available after you leave EG
• Select File Save Project As   Local Computer
• Navigate to the desired location
• Enter a name for your project and click OK.

You can build and run multiple flows in the same project and then 
toggle between them.  Let’s demonstrate by adding another flow to 
our project with help from the Code Analyzer.
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Help for your legacy Code too!

The Code Analyzer allows you to:

• Turn that old, 40 step SAS program into a Process Flow
• Create instant documentation:

• What steps are run
• How long does it takes to run
• What data is used and created in each step.
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Running the Code Analyzer

• In the Program context menu bar, select Analyze Program
Analyze Program Flow

• Select Begin Analysis
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Running the Code Analyzer

• Once the analysis is complete, select Create Process Flow.
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Running the Code Analyzer
A new flow is added to your project called Program_1 (defaults to 
name of the program node).  Note that the Code Analyzer did not
run the code and produce the results.  

• Run the new Flow: Right click on the starting dataset (SASHELP.Shoes)

• Select Run Branch from SASHELP.SHOES.
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Multiple Flows in the same Project

To toggle or switch between Process Flows, you can use the Project 
Tree View and double click on the Flow you want to look at.
You can also use the Drop down at the top of the Process Flow View.

• Toggle back to the Original Process Flow. 

• Select drop down arrow.

• Select Process Flow.

Helpful Hint: When working with multiple 
flows, it’s a good idea to rename them 
to something meaningful in order to 
keep them organized.  Right click on 
the Process flow in the Project Tree 
and select Rename.
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Part 6:  Using Tasks in EG 6.1

As experienced SAS programmers, you probably have a lot 
of familiarity with certain PROCs.  However, since the 
SAS language is extensive, there are probably many 
areas that you haven't explored.

One of the benefits of using Enterprise Guide is that Tasks
guide you through requirements and quickly produce 
results without YOU having to learn new procedures.

In addition to accessing tasks via the menu bar, the TASK 
GALLERY was added to EG 6.1 to provide you with 
visual access to all of the tasks, as well as extra 
information about the tasks. 



45

Part 7:  Adding some flexibility to your 
Enterprise Guide Project

 Project Prompts
 You can add Project Prompts (formerly known as 

Parameters) that will prompt the user for a response 
when running a task, query or code.

» Values that the user enters are available as macro 
variables 

» The user can enter a value or you can provide a 
list of values for the user to choose from.
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Project Prompts 
• Select View → Prompt Manager

• Select Add to add a new Prompt.

• Under the General tab, enter RegionID in the name section.

• Enter Please select a Region in the Displayed Text section.

• Select the Prompt Type and Values tab.

• In the Prompt Type Value dropdown, select Text

• In the Method for populating Prompt dropdown, Select User 
Selects values from a static list.

• Select Get Values… to identify the source of the static list.

When loading values from an underlying table, the possible value list is 
refreshed to make sure that it includes new values that may have 
been added in your data
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Project Prompts 
• Select Browse to load values from SASHELP.SHOES 

• Navigate to the SHOES dataset: Servers → Local →

Libraries → SASHELP → SHOES

• From the Columns dropdown in the Unformatted Values
section, select Region

• From the Columns dropdown in the Formatted Values section, 
select Region

• In the Available values section, under the Browse tab, select 
Get Values

• Move all values over to the Selected Values window.

• Select OK.



48

Project Prompts 
• In the List of Values, select Canada as the default value
and select OK

• In the Process Flow window, Right click on the 
Program_1 Code Node, and select Properties

• Select Prompts and select Add

• Select RegionID and select OK

• Select OK again to close the Program node Properties 
window.

RegionID now appears in the Prompt Manager View.
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Project Prompts

• Open the Program_1 code node

• In the program, ADD where Region = "&regionID"; in  
the Ex_Shoes_Data datastep

• Save the changes to your Program_1 code node

• Right click on the Program_1 code node, and select Run 
Branch From Program_1.

Now, modify your program so that the prompts control the 
report data.
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Project Prompts 

When prompted to select a Region, select Asia from the drop 
down list.  Select Run.

The reports now reflect data for only Asia.

REMINDER:  the temporary SAS data set resulting from 
Program_1 now reflects just one country.  If other tasks refer to 
this dataset, they will now run for just the subset of data.
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Part 8: Helpful Tips and Tricks
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Cleaning up after your co-workers

If you have inherited poorly formatted code…

• Right click anywhere in the Program
• Select Format Code

Helpful Hint:
Specify formatting preferences, or override the options

Tools → Options → SAS Programs → Editor Options → Indenter
.

set the spacing on indents and select which statements signal a new line.
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EG 6.1 - Log Summary
A great new feature was added to Enterprise Guide 6.1 – to help 
you quickly zoom in on issues - Log Summary window.

The Log Summary lists:
• all the errors, warnings, and notes that were generated when 

the program ran
• line numbers and a sample of the affected code.
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Helpful Hint: Update your options so that SAS EG does not 
try to open any new data when it is added to your project.

Tips for working with Large Data in EG

By default, Enterprise Guide is going to try to open any new data 
that you add to your project.  This can be time consuming  
when you add large database tables to your project view.

Select Tools → Options → Data

UNCHECK Automatically open data when added to project



55

Helpful Hint: Get info about table attributes without opening 
your data by assigning libraries in your server list

Tips for working with Large Data in EG

When the libraries in your server list are assigned (folder icon is yellow), you can 
retrieve the details about any tables in that library by right clicking the table 
name and selecting Properties

The Columns tab in the property window will list all of the columns in that table, 
along with their type, length and format

To assign a library, right click on the library name and  select Assign

This allows you to get some more information about your data without            
having to open it up from the source.
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Project Recovery

 Enable Project Recovery
 EG will autosave your project based on the interval you set.
 Select Tools → Options → Project Recovery
 Select Enable Project Recovery.
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Autoexec Processing
 If you have some code or a flow that you want to execute 

whenever your Project is opened, create a Process Flow named 
Autoexec.

 Enterprise Guide will detect that there is an Autoexec flow in 
your project and will execute it whenever your project is opened. 

 By default, Enterprise Guide will prompt you to run the Autoexec 
flow.  If you don’t want to be prompted before it runs, select

Tools → Options → General and check the box that says:
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Sharing your Projects with Others

Helpful Hint: When creating projects that will be shared and 
run by others, you can add descriptive notes to your 
project that explain what the project and each task is 
doing.  For example, you can add details around changes 
that may need to be made to the code, where the results 
are going, what input is expected, etc.

• Select File → New → Note
• You can link each note to specific tasks:

• Right-click on the note node, select Link Note to…
• Select the task or code node that you want to link to 
• Select OK.
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Emailing Notes

 Email a note to communicate information about your 
job
 Notes added to your project can be emailed (if your site 

supports this)
 Combine notes with conditional processes.
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 Export all the code from your project
 Once you’ve completed your work, you may have a mix 

of tasks and custom code nodes.  You can save these 
in a single SAS file.

 Select File → Export → Export All Code
 You can choose which elements in your project you 

want to include in this final .SAS file and which order 
the code should appear. 

Exporting Code
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Ordered Lists of Task

 You can create an Ordered List of tasks or .sas code 
nodes to run 
 You can specify any order for the tasks
 The ordered list of tasks will run sequentially.
 To create an ordered list, select File  New  Ordered List.
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Running Tasks in Parallel
Starting in EG 5.1, you can run tasks and process flow paths in
parallel on the same server instead of having to wait for them to
run one at a time.  

This can be enabled at the task level or at the Project level. 

• To set tasks to run in parallel, go to File  Project Properties.
• Go to the Code Submission window and make sure that the 

“Allow parallel execution on the same server” box is 
checked.

Now if you are running more than one task in separate branches, 
you’ll notice that they aren’t cued up waiting to run one after the 
other.  They will run at the same time.
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Running Tasks in Parallel
You can also control this at the individual task level by right clicking 
on the task, and selecting Task Properties.  

Under the Code Submission view, you can select to either use the 
settings set at the Project level, or customize the options for the 
specific task.

Helpful Hint:  you may be launching more than one workspace 
server connection when running in parallel, so changes that you 
make in one session (adding macro variables, libraries etc) may 
not get picked up in the tasks or code that is running in the other 
session.  
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Ready to get started…
With the basics now in place, you are ready to find 

out what else you can do with Enterprise Guide
 Build conditional flows to add more logic and flexibility
 Understand the differences when using Enterprise Guide 

in a Server Environment
 Explore the built-in tasks; create your own custom tasks; 

or build projects to share with others

 Expand your knowledge with
 Q+A from a similar talk - Chris Hemedinger’s post 

http://blogs.sas.com/content/sasdummy/2014/02/17/favori
te-eg-tricks-fecht/
 Free tutorials / learning opportunities on the web
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